Electrical Design Software | Elecdes Design Suite by Scada Systems Ltd

Interface Overview

The Cable Scheduler program has a menu and toolbar at the top of the main window that are fixed in place. Each open project has its own window within the main window. The project windows display the data from the project database in different modes to suit different editing purposes: list, edit and connection view.

Main Menu

Cable Scheduler has folders of categories in a tree like structure on the left side of the screen. Some reporting functions are only available from the File menu. Configuration options can be found either on the View or Tools menus. The Edit menu contains the same functions as the pop-up menu for the currently selected item in the category tree.

Toolbar

Underneath the main menu is a toolbar. This provides buttons to create or open a project and to display the help. The remaining buttons switch between the different editing views, outlined below.

Pop-up Menu

Most items in the Cable Scheduler windows have a pop-up menu. The pop-up menu has editing options specific to the item for which it is displayed.

To display the pop-up menu for an item, move the mouse over the item and click the right mouse button.


Category Tree

The category tree shows a summary of all of the data stored within a Cable Scheduler project. The category tree is always shown on the left side of a project window. Each item in the project database is summarised by displaying its "name" in the category tree. For example, the "name" would be the tag for a device. Items that are present on drawings in the Elecdes project have an overlaid E. Items that have been inserted in Cable Scheduler will not have an overlaid E.

The entries in the tree are structured such that related entries are grouped together under categories. You can expand and collapse categories as necessary to view or hide the entries within them.

Components contained within other components, for example devices in an area, display "links" under their container component. Thus a device may appear in more than one place in the tree: once in the appropriate device category, and also as a link under the area into which it has been placed.


Data Lists

The two data lists show more details about the item currently selected in the tree. The two data lists are always shown one above the other on the right side of a project window.

If a category is selected in the tree, then the top list will show the items contained in that category. The bottom list will show the ratings record for each component.

If a component is selected in the tree then the top list will show the details of that component. The bottom list will show the components contained within the selected component, for example terminal strips in a selected enclosure.

Both data lists can switch between a list and an editor. To change the view, from the View menu choose either List View or Edit View. You can also double-click the left mouse button in list view to switch to edit view.

List View and Edit View

List view and edit view are used to add, delete and edit components. For both views, the project window is divided into two main areas of control: a category tree on the left and two data lists on the right. Switching between list and edit view changes only the data lists. The category tree remains the same. The divider bars between the trees and lists can be moved to resize your views.

List View



Initially the view will contain lists of components or component data. List view provides an interface for operating on each entry as a whole entity. In the list view, you can select multiple components to edit simultaneously. The pop-up menu in the list view generally has options to add, copy, delete and edit components.

Edit View



The list view can be switched to a row and column editor. This shows the same rows and columns as the list view; however you can type data directly into the cells.

A dragged selection in the edit view will select multiple cells, however does not select whole components. This cell selection is provided to edit the data of the components.

In the edit view the pop-up menu options relate only to editing the data within the selected cells. For example: cut, copy, paste and increment. You can paste data from other programs into the edit view.

Filtering the list and Edit Views

The list and edit views can be quickly filtered allowing you to reduce the volume of components in the list to a manageable quantity.

For example you may wish to work with some cables, however there are 5000 cables in your list. You are however only interested in cables connected to enclosure P1. You can filter the column <From PNL> to show only cables containing a connection to "P1", limiting the list to contain only the 30 cables connecting to enclosure P1.

The filtering is achieved by clicking on the RIGHT SIDE of the grey column header bar at the top of the column of interest. An edit box will open under your mouse and you can enter the text you wish to match in the column. You can use the wildcard ' * ' in the filter text that you enter. E.g. P1* (in our above example) will also list cables connecting to P10 and P123.

Press enter to confirm your filter and return to the list/editing session.

To remove all filters from a column, open the edit box then press <SPACEBAR> then <ENTER>.

The current filter string is displayed in the grey column header bar if a filter exists.


Quickly Sorting the list and Edit Views

The list and edit views can be quickly sorted by any column by clicking on the LEFT SIDE of the grey column header bar at the top of the column of interest. An "ascending" sort will result based upon that columns data. If you click on the LEFT SIDE of the grey column header bar at the top of the column, a second time, then the view will revert to a "descending" sort based upon that columns data


Connection View



Connection view is used to connect components with cables. The display in connection view is divided into four panes. The top three panes display category trees for equipment, conductors and equipment again, in that order. The bottom pane displays a preview of the connections associated with the component or conductor that is currently selected in the trees above. The divider bars between the panes can be moved to resize your views.

The connection view is designed so that you can use drag and drop operations to make connections between equipment and conductors. You can drag equipment from one of the outer trees onto cables in the centre tree to make a connection. The drag operation can also be done from the conductors to the equipment.

See also:

Category Tree

Components

Report Generation