Electrical Design Software | Elecdes Design Suite by Scada Systems Ltd

FelixCAD Information for AutoCAD Familiar Users

This section contains information and instructions for AutoCAD familiar users who are now using FelixCAD. Some functions and facilities in FelixCAD differ to the AutoCAD counterparts and hence will need to be re-learned. We have identified all of the Elecdes relevant issues below.

Files

FelixCAD by default saves a .FLX format drawing file. Inside Elecdes for FelixCAD, we force FelixCAD to also save a .DWG file (R14) whenever any save operation occurs. Elecdes will refer to the DWG files whenever database operations need to scan drawing file data [e.g. reports / on line xref]. Elecdes also offers .DWG files as the default for the OPEN and NEW file commands.

FelixCAD font files are .FSH files. Occasionally when using an Elecdes symbol you will find that FelixCAD requires you to select a compatible .FSH file to match a missing AutoCAD FONT name. Select a suitable FSH and operations can continue normally.

User Interface/Screen Appearance

The FelixCAD command line is always shown. Aside from this, it behaves similarly to the AutoCAD command line.

The FelixCAD pull-down menus are not arranged exactly like AutoCAD's. You should familiarise yourself with these and learn the location of your commonly used menu items.

On the left side of the FelixCAD screen, FelixCAD provides icons for LAYER, LINETYPE and COLOR change. There is also a PAN and ZOOM facility. These are all useful tools and you should familiarise yourself with them. The Object Snap (OSNAP) options in FelixCAD are in an optional palette (or toolbar) – see below.

When running commands an OPTIONS "menu" will often appear. This menu allows for easy selection of the options for the command you are using. e.g. If running the ZOOM command you will be offered items to select "WINDOW" and "EXTENTS" etc. You may click on these instead of entering "W" or "E" on the command line. You can change the settings so that FelixCAD displays a toolbar or does not display options in the FelixCAD menu: File > Desktop Manager > Options.

FelixCAD does not have GRIPS. You can modify attribute positions using ATTMOVE. You can modify the endpoints of lines using CHANGE.

FelixCAD allows up to 4 drawings to be open in one cad session. Elecdes functions will always run on the "Currently Selected" drawing that you have open. Click in a drawing to use Elecdes functions on it.

"Toolbars" are "palettes" in FelixCAD

A FelixCAD "palette" is a "toolbar". You can choose the FelixCAD palettes to display from the FelixCAD menu: File > Palette Manager.

"Blocks" are "parts" in FelixCAD

FelixCAD refers to "blocks" as "parts". Most functions for creating, inserting or modifying parts in the "Parts" pull-down menu. The Parts menu includes all of the functions for modifying the attributes of parts.

Commands

STRETCH

We have provided an ALIAS of "ST" to run the stretch command.

Menu: Modify > Stretch.

DDATTE

This is an ALIAS we have provided for the FelixCAD ATTXEDIT equivalent.

Menu: Parts > Edit Part Attributes.

ATTMOVE

Replaces the AutoCAD ATTEDIT - MOVE, attribute moving function.

Menu: Parts > Modify Attribute Text > Move Attribute Text.

ATTROT

Replaces the AutoCAD ATTEDIT - Rotate, attribute rotate function.

Menu: Parts > Modify Attribute Text > Rotate Attribute Text.

FONT

Replaces the AutoCAD STYLE function.

Menu: Detail > Fonts.

DDMODIFY

Is an AutoCAD command with no equivalent in FelixCAD.

Use ATTDEDIT for attribute definition changes while editing a symbol.

Menu: Parts > Modify Attribute Definition.

Use CHPROP or PROPEDIT for other entities.

Menu: Edit > Modify Object Properties.

QTEXT

Replaces the AutoCAD TEXT and DTEXT function.

Menu: Detail > Single Line Text.

QINSERT

Replaces the AutoCAD INSERT function.

Menu: Parts > Quick Insert...

Menu: Parts > Insert part...

COPYSELECT

and PASTE

Replace the AutoCAD COPYCLIP and PASTECLIP functions that allow you to copy entities from one drawing to another.

NOTE: The FelixCAD COPYSELECT function requires you to select a base point.

Menu: Edit > Copy Selection to Clipboard.

Menu: Edit > Paste Selection from Clipboard.

ZW

Is a fast command for ZOOM WINDOW.

LTSCALE

Is not measured in the same units as in AutoCAD. Re. FelixCAD documentation.